SlideShowPro pour Lightroom

Après tout juste une semaine de retard (par rapport à l’annonce officielle), SlideShowPro pour Lightroom vient de voir le jour. Il faut avouer que les template « Web » livrés avec LR sont relativement basiques et SSP devrait mettre un peu de gaieté dans tout ça. Personnellement, je ne comprends pas tout à fait pourquoi il aura fallu attendre la version 1.3 de LR pour voir apparaître ce template. En effet, ce n’est ni un module d’export, ni un module à part entière… Néanmoins, il est là et semble offrir la même apparence que les produits de la marque. Le petit plus de SSP est sans doute sont mode « plein écran » qui permet de visionner vos photos sans que l’on ne voit votre navigateur web. Un véritable diaporama ! Pour 25$, cela vaut le coup :-) Ma galerie réalisée avec SSP.
Attention mise à jour du 10/12/07: Inhiber le téléchargement d’une photo…à voir en fin d’article


La bonne surprise

Après avoir téléchargé (et payer car il n’y a pas de version d’évaluation…) puis installé le template (dans le repertoire galerie de LR), on ouvre LR en « mode » [Web] et là, miracle, SSP pour LR est disponible. Les menus de paramétrages sont nombreux et complets. D’ailleurs, de nombreux essais vous permettront de mieux les assimiler… La bonne surprise vient du fait que l’on peut facilement créer un index pour naviguer entre plusieurs albums. Malheureusement, cela n’est pas « automatique » et vous aurez quelques manipulations de fichiers .xml et de copier/coller de répertoires à réaliser. Mais rassurez-vous, rien de bien compliqué. Cela se fait d’ailleurs de manière plus simple que celle expliquée ici ;-)

Pour voir un exemple, cliquez sur ce lien…et essayez tout les boutons de l’affichage. Surtout celui en bas à gauche et celui à droite :-)

Un fil a été ouvert sur Forum.Utiliser-Lightroom.fr

Créer un seul et unique album ne pose pas de problèmes, mais les choses se complique si vous désirez indexer plusieurs albums avec SSP. Rassurez-vous, l’opération reste toutefois réalisable avec un peu de méthode ;-)

Créez un index


Modifier les répertoires qui contiennent vos photos

1/ Exportez normalement sur votre DD votre premier album (galerie1).

2/ Faites de la même manière avec un second album en le plaçant dans un autre répertoire sur votre disque dur (galerie2).

Veillez à bien remplir les champs correspondants aux informations de votre album

3/ Renommez en « album2 » le répertoire qui se trouve dans votre 2ème galerie.

4/ Déplacez le dans le répertoire de votre 1er galerie. Vous aurez donc 2 répertoires d’images: Album1 et Album2.

Modifiez les fichiers « images.xml »
1/ Ouvrez le fichier « Images.xml » de votre 2ème galerie avec Notepad ++

2/ Remplacez tout ce qui est « album1 » en « album2« .

Appuyez sur Ctrl et F

3/ Ouvrez le fichier « image.xml » de votre première galerie.

4/ Copiez les lignes qui se trouvent entre les balises « Album » du fichier xml de votre 2ème galerie.

5/ Collez les lignes dans le fichier « Images.xml » de votre 1er album.

6/ Enregistrez le fichier ainsi modifié.

7/ Transférez tout ce qui se trouve dans le répertoire de votre 1er galerie sur votre serveur.

Inhiber le téléchargement de vos photos


Dès la V1.0, il avait fallu pallier à un oubli des programmeurs de SSP. Depuis, le tir a été rectifié et l’astuce qui auparavant présente dans ce chapitre n’a plus lieu d’être, c’est pour cela que cet article a été modifié. Les nouvelles versions proposant automatiquement cette possibilité à partir de LR.

Décochez cette case

27 réflexions au sujet de « SlideShowPro pour Lightroom »

  1. Seb

    Précision sur l’index…

    Lors d’ajout de galeries, vous n’aurez pas à tout "réimporter" comme c’était le cas avec la méthode de Matthew Campagna.
    Malheureusement il faut continuer à "bidouiller" des fichiers et cela manque d’automatisme…

    Malgré tout, je garde un "bout" de script pour différencier mes galeries perso de celle qui ne le sont pas.

    Donc, j’aurais à terme "l’entrée" de ma zone "Galerie" qui se fera via le template de Matthew (le simple TTG), et ensuite, les sections "Public" & "Privé" seront visualisables avec SSP pour LR.

    Mais il faut avouer que LR a encore du chemin à faire sur ce point. Et surtout sur la possibilité de "verrouiller" l’accès à certain "profil".

    Mais c’est déjà plus sympathique que ce que propose C1 V4 ou Expression Media…

    Seb

    Répondre
  2. Picounet

    Je viens de télécharger le plug-in, je devine qu’il faut ouvrir celui-ci dans le répertoire :
    C:\Documents and Setting\administrateur\Application Data\Adobe Lightroom Web
    Je n’arrive pas a trouver ce fichier…
    Pourriez-vous éclairer ma lanterne

    Répondre
  3. Seb

    Picounet,

    Désolé, je n’avais pas consulté mes emails hier soir…

    Pour ceux qui se poseraient aussi la question:
    Avec un PC sous windows Xp, voici à quel endroit doit être placé le template:

    C:\Documents and Settings\ [nom d’utilisateur] \Application Data\Adobe\Lightroom\Web Galleries

    Cdt

    Seb

    Répondre
  4. SHEST

    Bonjour,
    j’ai un problème avec l’apercu de mes index en effet ils sont pixelisés, j’ai testé avec lightroom / director ssp et flash / director ssp et je ne comprends toujours pas pourquoi ils sont d’aussi mauvaise qualité, pourtant je créé mon fichier dans photoshop et lenregistre en 72 dpi, en jpg et aux bonnes dimensions…

    Je me permets de laissé ce lien ou j’ai détaillé mon problème avec des capture d’image :
    forum.utiliser-lightroom….

    Merci Seb de tes explications qui nous permettent d’avancer toujours plus efficacement.

    SHEST

    Répondre
  5. Seb

    Bonjour,

    Comme ça ? Je ne comprends pas le fait que ça ne fonctionne pas en local…? Une fois les galeries envoyées sur le serveur ça marche, mais pas si les répertoires restent sur votre DD ?

    Seb

    Répondre
  6. Dom

    Bonjour,
    Est ce que vous avez déjà imbriqué le SldeshowPro dans une page HTML.
    J’ai bien lu le PDF en Anglais, mais il doit y avoir quelque chose qui m’échappe, je cale ?

    Répondre
  7. Seb

    Bonsoir,

    Je ne l’ai jamais fait. Je viens néanmoins de faire des tests et ça semble fonctionner. Je vous promet de vous fournir l’explication en détail au plustard courant du week-end ;-)

    Amicalement

    Seb

    Répondre
  8. damien

    Bonjour seb, j’ai suivi tes conseils pour inhiber le téléchargement des photos.
    Cependant lorsque l’on passe la souris sur les photos d’un album un main s’affiche et on peut cliquer comme pour un lien, qui affiche une page qui n’existe pas.
    Comment peut-on faire pour enlever ce lien???
    Tu peux voir un test que j’ai fait à l’adresse suivante: damiencouvreur.fr/test112

    Merci!

    Répondre
  9. Seb

    Salut Damien,

    Depuis les récentes versions, on peut le désactiver les liens en décochant la case — "Attach Hyperlink"– dans le menu "image".

    Dès lors, la "main" n’apparait plus ;-)

    Seb

    Répondre
  10. Jonathan

    Bonjour,

    j’utilise SSP et j’essaie de mettre de la musique dans mes galeries, ça marche très bien dans lightroom mais apparement pas à l’export???

    Quelqu’un a t il la solution?

    Merci

    Jonathan

    Répondre
  11. Dom

    Jonathan, ton export si tu l’ouvres sur ton disque dur tu n’as rien, mais si tu upload ton export sur ton serveur, alors tu as ta musique.

    Répondre
  12. Seb

    Je n’utilise pas de musique. Je préfère garder la bande passante pour le chargement de mes photos. ;-)

    Mais je suis bien heureux que quelqu’un puisse répondre. Mais je testerai tout de même cette fonctionalité.

    Amicalement

    Seb

    Répondre
  13. Seb

    Il faut décocher la case "Copyright". Je pense que ça devrait suffire ;-) Maintenant, c’est peut-être dû à la version d’évaluation…une copie d’écran permettrait de lever le doute.

    Répondre
  14. JLCphoto

    Bonjour, J’ai 2 questions concernant l’usage de SSP.
    1-Comment peut-on créer un lien pour revenir vers des pages créées avec un autre produit (dreamweaver par exemple)?
    2-Comment ajouter de la musique autrement qu’en précisant l’url où celle-ci se trouve. Par exemple en ayant un dossier « music » dans album1.
    C’est là que j’ai mis la musique, mais j’ai dû mettre l’url complet alors que l’on pourrait mettre un url relatif, ce qui permet de transporter l’ensemble produit.
    Merci de votre réponse.

    Répondre
  15. Dom

    As tu une idée Seb, pour quelle raison les transitions de syle, comme cross fade, drope, push, dissolve etc….sont toujours SACCADE ?
    J’ai beau essayé de changer les temps « transition length »

    Répondre
  16. Seb

    Il semblerait que le dernier moteur java de SSP soit à l’origine de ce problème… Du coup, j’ai gardé celui de la version précédente…

    Répondre
  17. David

    Bonjour,

    je cherche à mettre plusieurs galeries SSP sur un site en Flash, mais le problème et que tous les fichiers créé par SSP ont le même nom. J’aimerai savoir s’il est possible de changer le nom du fichier images.xml ? (si celui est changeable, le pb est résolu…)

    Répondre
  18. Seb Auteur de l’article

    Bonjour,

    Avez-vous regardé ce qu’il est possible de faire avec Director du même éditeur ?

    J’avoue ne me contenter que de cette version sans aller plus loin.

    Je préfère les sites HTML ou ceux qui mixent flash et Html…

    Un lien vers votre site pour voir comment vous voulez faire ?

    Répondre
  19. Yann

    Bonjour,
    Effectivement, les transitions sont très saccadées. Je viens d’acheter SSP 1.3.5 pour Lr2. Comment faire pour utiliser l’avant-dernier moteur Java de SSP, quand on a que la denière version de SSP ? Oû le trouver et comment le remplacer ?
    Merci d’avance.

    Répondre
  20. Seb Auteur de l’article

    Pour remplacer le nouveau moteur par l’ancien:

    1/ Télécharger et enregistrer sur votre DD le fichier qui se trouve ici : http://fotopassion.fr/Utilitaires/slideshowpro.zip

    2/ Faite une recherche sur votre DD de « slideshowpro.swf »

    3/ Décompressez le fichier télécharger à l’emplacement précédemment trouvé.

    ——————————————-

    Sinon, vous pouvez le charger aussi directement sur votre serveur.

    Amicalement

    Seb

    Répondre
  21. Yann

    Pas de problème avec l’ancien, c’est vrai !
    En fait, le problème (avec le nouveau moteur Java) se pose lorsque la taille des images (large width / large height) dans l’album est supérieure à la taille de SSP (SSPro width / SSPro height) en ayant choisi en Content Scale « Downscale Only » ou « Proportional ».
    Lorsque les images sont plus petites ou égales aux dimensions de SSP, les transitions ne sont pas saccadées.

    Merci pour l’aide précieuse.
    Yann

    Répondre
  22. Jean-Claude

    Bonjour,

    Dans ce template, « SlideShow pour lr », j’ai un problème avec le lien de mon logo.
    Je remplis la case « Logo Link » avec mon adresse : « www.maintenant.ch » (correctement enregistrée dans le fichier param.xlm) et ça charge sur le web l’adresse suivante : « http://www.maintenant.ch/essai1/www.maintenant.ch » qui évidemment n’aboutit qu’à l’erreur 404.

    (P.S. capture d’écran sur http://forum.utiliser-lightroom.fr/index.php/topic,1278.0.html )

    Merci de m’éclairer,
    Salut, Jean-Claude

    Répondre

Répondre à Yann Annuler la réponse

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *